Support: Audio Issue - Inbound Calls to Support
Incident Report for Finalsite
Resolved
Our Support platform provider has confirmed that call functionality has been fully restored. Thank you for your patience!
Posted Apr 22, 2024 - 14:19 EDT
Identified
Our team is aware of an issue where the audio on some inbound calls to Support is not working as expected. Our Support platform provider is working on the issue and we will provide additional information soon. In the interim, please submit a Support ticket in the event you encounter an audio issue. Thank you for your patience and understanding!
Posted Apr 22, 2024 - 11:02 EDT
This incident affected: Additional Components (Finalsite Support (Phone Support and Tickets)).