Composer Performance Issues

Incident Report for Finalsite

Resolved

A fix has been deployed to all affected websites, and this issue is resolved. If you require any additional assistance, please contact Composer Support.
Posted Dec 04, 2025 - 22:00 EST

Update

A fix is being deployed to all affected websites at this time. We will provide an update when this rollout is complete.
Posted Dec 04, 2025 - 20:29 EST

Identified

Our team has identified the cause of these display and performance issues and is working to implement a fix. We will provide an additional update as soon as we have more details.
Posted Dec 04, 2025 - 17:26 EST

Investigating

We are currently investigating issues with Composer performance and display in the US West hosting region. We are working to address these issues and will provide an additional update as soon as possible.
Posted Dec 04, 2025 - 12:33 EST
This incident affected: School Websites (Composer US West).