Finalsite Enrollment: Microsoft Login Unavailable

Incident Report for Finalsite

Resolved

Тhe incident has been resolved and login through Microsoft (Azure) is now restored.
Posted Jul 02, 2026 - 16:46 EDT

Identified

Parents and admins that sign into FS Enrollment using Microsoft (Azure) Login are currently not able to access the application and will see a red error message upon attempting to log in.

We have identified the cause of the issue and are working to quickly remediate this. Thank you for your patience & understanding.
Posted Jul 02, 2026 - 13:59 EDT

Investigating

We are currently investigating this issue.
Posted Jul 02, 2026 - 13:44 EDT
This incident affected: Enrollment Management System.