Composer Performance Issues

Incident Report for Finalsite

Monitoring

We are seeing performance improved at this time across all US Central websites, and we are continuing to monitor.
Posted Sep 01, 2026 - 13:30 EDT

Investigating

We are currently investigating issues with a subset of Composer websites in the US Central. We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Sep 01, 2026 - 12:25 EDT
This incident affects: School Websites (Composer US Central).