Subset of sites slow to respond or failing to load

Incident Report for Finalsite

Resolved

Our engineering team has, from what we've seen as of roughly 6:40 Eastern time, been able to restore service to affected districts. We do not yet have a root cause available for the disruption, but we believe that sites should again be operational.
Posted Feb 19, 2025 - 18:47 EST

Investigating

As of roughly 5:45 PM Eastern time, we became aware that a subset of WCM sites is loading slowly or is failing to respond. Our engineers are currently investigating and hope to restore normal service soon.
Posted Feb 19, 2025 - 18:25 EST
This incident affected: School Websites (Web Community Manager).