Issues with Composer sites

Incident Report for Finalsite

Resolved

This incident has been resolved. We apologize for the inconvenience.
Posted Aug 07, 2026 - 11:34 EDT

Monitoring

We're seeing sites stabilize and are continuing to monitor the situation.
Posted Aug 07, 2026 - 09:09 EDT

Investigating

We're currently investigating an issue with Composer sites. We'll provide more updates here as they become available.
Posted Aug 07, 2026 - 08:42 EDT
This incident affected: School Websites (Composer US Central).