Mass Notifications: Site error message for some clients
Incident Report for Finalsite
Resolved
This issue is resolved
Posted Sep 19, 2024 - 15:01 EDT
Identified
For a small subset of clients, the Mass Notification site might not load, resulting in an error message. We are working to resolve this issue quickly.
Posted Sep 19, 2024 - 14:24 EDT
This incident affected: Community Engagement Products (formerly Blackboard K12) (Mass Notifications).