We continue efforts to restore service. You may begin to receive new credentials in your inbox. As access to your account is restored, please know that SMS and Voice deliverability is degraded. Please utilize Email or your back up communication channels.
Posted Oct 07, 2025 - 05:38 EDT
Update
We are continuing with security testing and system validation to ensure a safe restoration. Please plan for systems to remain offline through tomorrow, Tuesday, October 7th.
Posted Oct 06, 2025 - 20:14 EDT
Update
We are actively working to restore service and are aiming for full restoration later today. Please continue to monitor your email inbox and this status page for further instructions.
Posted Oct 06, 2025 - 14:14 EDT
Identified
We are working to gradually restore service. Please continue to monitor this page for updates on restoration progress throughout the day. Also, please monitor your email inbox for more details regarding access to your account.
Posted Oct 06, 2025 - 07:17 EDT
Investigating
We need to perform emergency maintenance on our services. At this time, your Mass Notifications, Messages XR-E, and Connect products will not be accessible. We apologize for the inconvenience and understand the disruption this maintenance causes.
Posted Oct 05, 2025 - 03:43 EDT
This incident affected: Communication Tools (Connect, Mass Notifications, Messages XR Enterprise).