Degraded Performance Issue

Incident Report for Finalsite

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 11:16 EDT

Monitoring

A fix has been implemented for all affected sites, and our team is continuing to monitor at this time. Thank you for your patience, and please contact Support if you are seeing any lingering issues.
Posted Aug 04, 2025 - 09:39 EDT

Identified

Our team has identified the root cause for these site performance issues, and are in the process of deploying a fix to all affected websites. We will provide another update soon.
Posted Aug 04, 2025 - 09:16 EDT

Update

We are continuing to investigate this issue that is impacting a subset of websites. We will provide additional updates as soon as possible.
Posted Aug 04, 2025 - 08:25 EDT

Investigating

Our team is investigating reports of performance/availability problems on your website. We will provide additional information as soon as possible.
Posted Aug 04, 2025 - 08:02 EDT
This incident affected: School Websites (Composer US East).