Messages XR Enterprise and Mass Notification: Message Sending Delays for a Subset of Clients

Incident Report for Finalsite

Resolved

The issue that was causing message sending delays for a subset of clients has been resolved.
Posted Nov 18, 2025 - 16:21 EST

Monitoring

We are seeing message sends process as expected at this time, our team is continuing to monitor.
Posted Nov 17, 2025 - 17:15 EST

Identified

Our team is continuing to work on this issue, and sending delays may remain for a subset of clients. We will provide an additional update as soon as possible.
Posted Nov 17, 2025 - 15:51 EST

Investigating

Our team is aware of a message-sending delay impacting a subset of clients using the Messages XR Enterprise and Mass Notification platforms. We are working to address this issue and will provide additional updates as soon as possible.
Posted Nov 17, 2025 - 14:07 EST
This incident affected: Communication Tools (Mass Notifications, Messages XR Enterprise).