Connect is currently experiencing phone system issues.

Incident Report for Finalsite

Resolved

This phone issue has been resolved. The phones are operating as expected.
Posted Dec 06, 2023 - 17:00 EST

Identified

We are currently experiencing issues with our phone systems. Please reach out to us at connectsupport@finalsite.com if you need assistance. We apologize for the inconvenience and will provide updates as they are available.
Posted Dec 06, 2023 - 16:17 EST
This incident affected: Communication Tools (Connect).