Messages/XR: Sending Delays for US East

Incident Report for Finalsite

Resolved

This issue with sending delays has been resolved.
Posted Oct 16, 2025 - 15:52 EDT

Monitoring

We are seeing message sends process as expected at this time, our team is continuing to monitor.
Posted Oct 16, 2025 - 14:21 EDT

Identified

Our team is continuing to work on this issue, and sending delays may remain for a subset of clients in the US East region. We will provide an additional update as soon as possible.
Posted Oct 16, 2025 - 13:55 EDT

Investigating

Our team is aware of sending delays from the Messages/XR platforms, impacting a subset of clients in the US East hosting region. We are working to address this issue and will provide additional updates as soon as possible.
Posted Oct 16, 2025 - 12:25 EDT
This incident affected: School Websites (Composer US East) and Communication Tools (Messages XR).