Connect: SMS Sending Issue

Incident Report for Finalsite

Resolved

SMS delivery has remained normal throughout the day, with no further disruptions reported by our upstream provider. This incident has been resolved.
Posted Aug 17, 2026 - 16:15 EDT

Monitoring

Our upstream SMS partner is no longer observing any further issues, but they continue to monitor their services closely. Outgoing SMS delivery is returning to normal, and our team will continue monitoring delivery rates to ensure stability.
Posted Aug 17, 2026 - 08:38 EDT

Update

We are currently investigating an issue affecting SMS delivery due to a service disruption with an upstream infrastructure partner.

Impact: Messages may remain in your outbox with a "sending" status for longer than usual, or they may fail to deliver entirely.

We are actively working with our partner to restore full service.
Posted Aug 16, 2026 - 20:23 EDT

Investigating

We are currently investigating an issue that is causing SMS messages to stall in the outbox. Our engineering team is actively investigating this matter to identify the root cause. Further updates will be provided as soon as more information becomes available.
Posted Aug 16, 2026 - 18:03 EDT
This incident affected: Communication Tools (Connect).