Finalsite Enrollment: Degraded Email Open Dates

Incident Report for Finalsite

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 13:44 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2026 - 13:33 EDT

Identified

Open dates in our Sent Emails page are currently empty due to an intermittent issue with our external email delivery provider. We are working with our email provider to resolve the issue as soon as possible.

Emails are still being successfully sent and opened by recipients.
Posted Mar 23, 2026 - 12:01 EDT
This incident affected: Enrollment Management System.