Performance Issues: Composer, Connect and Web Community Manager
Incident Report for Finalsite
Resolved
This incident has been resolved. Please reach out to our Support Team if you are experiencing any additional issues.
Posted Jul 19, 2024 - 14:03 EDT
Monitoring
Composer US Central and Composer US West are now operational. Restoration across all Composer regions has now been completed and we are continuing to monitor performance.

If you are still experiencing any issues related to this incident, please contact Support. Thank you for your patience and understanding as our team worked to address this issue.
Posted Jul 19, 2024 - 11:36 EDT
Update
Connect, Composer UK, Composer Asia, and Composer US East are now operational.

Work continues to restore Composer access and performance across all regions. Further status updates will be provided as soon as possible. We have reached 70%+ recovery across our platform.
Posted Jul 19, 2024 - 10:22 EDT
Update
Finalsite, as well as hundreds of other major businesses worldwide, have been impacted by a software update issue from CrowdStrike. CrowdStrike provides endpoint and server protection.

Performance has been restored for WCM, but issues for Connect, Composer, and its connected modules like User Login, Athletics, Calendars, and Messages remain. Engineers have been working around the clock on this and are working towards a resolution. Although CrowdStrike has since rolled out a fix, the implementation is manual.

We are beginning to see recovery and will continue to provide updates as we make additional progress.
Posted Jul 19, 2024 - 08:41 EDT
Update
Work continues on a fix for this issue. Performance has been restored with Web Community Manager, but issues on Composer and Connect remain. Thank you for your continued patience as our team works on this with urgent priority.
Posted Jul 19, 2024 - 05:49 EDT
Identified
Our team remains actively engaged in addressing this issue. Primary known impact(s) at this time include admin user logins and back-end access, while front-end websites remain available. We will provide additional updates as soon as possible.
Posted Jul 19, 2024 - 03:49 EDT
Investigating
Our team is aware of performance issues currently impacting the Composer, Connect and Web Community Manager environments. We are actively investigating at this time, and will provide additional guidance as soon as possible.
Posted Jul 19, 2024 - 03:01 EDT
This incident affected: Composer CMS (Content Management System) (Composer US East, Composer US Central, Composer US West, Composer UK, Composer Asia) and Community Engagement Products (formerly Blackboard K12) (Connect, Web Community Manager).