Connect: Email Reporting Issue

Incident Report for Finalsite

Resolved

Reporting is now back to normal, and we are no longer seeing large numbers of messages stuck in “Email Sent” status.

Please note that delivery status updates are still subject to responses from email providers, so there may occasionally be slight delays depending on the recipient’s provider.

If you notice anything unusual, please don’t hesitate to reach out to our Support team.
Posted Sep 10, 2025 - 08:53 EDT

Investigating

We are currently experiencing an issue with message reporting where some emails are returning a status of “Email Sent.” Please note this is a reporting issue only. Emails are still being delivered successfully.

Our development team is actively investigating, and we will provide updates as more information becomes available.
Posted Sep 05, 2025 - 16:56 EDT
This incident affected: Communication Tools (Connect).