Connect - Degraded SMS Sending

Incident Report for Finalsite

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 07:26 EST

Monitoring

We are seeing performance return to normal and will continue to closely monitor the situation.
Posted Feb 18, 2026 - 19:49 EST

Investigating

Our team is investigating SMS sending delays and degraded performance.
Posted Feb 18, 2026 - 18:19 EST
This incident affected: Communication Tools (Connect).