Messages Incident: Some Emails Not Being Delivered
Incident Report for Finalsite
Resolved
Our development team has released a fix for the issue causing some recipients to not receive emails sent via Groups, Constituent Picker, or Dynamic Lists. We apologize for the inconvenience this may have caused you and thank you for your patience while we worked to resolve this issue.
Posted Dec 18, 2024 - 12:02 EST
Investigating
We have identified an issue that may prevent emails from being sent to recipients via Groups, Constituent Picker, or Dynamic Lists (lists that contain Groups) that have email addresses stored containing certain attributes (i.e. capitalizations). This also affects Important Announcements.

As a temporary workaround, you can send Promotional Messages or use Lists containing email addresses only (no Groups). We are working to resolve this as quickly as possible.

Please contact Finalsite Support with any questions or concerns.
Posted Dec 17, 2024 - 12:11 EST
This incident affected: Composer CMS (Content Management System) (Composer US East, Composer US Central, Composer US West, Composer UK, Composer Asia).