US Central - Composer Display Issues

Incident Report for Finalsite

Monitoring

A fix was deployed overnight, and as of 7:00 AM CST, all affected sites have been updated to the latest version. We are continuing to monitor performance. If you continue to experience issues, please contact Support. Thank you for your patience.
Posted Feb 11, 2026 - 08:34 EST

Identified

The root cause of this issue has been identified, and our team is working to implement a fix. We will provide additional updates as soon as possible.
Posted Feb 10, 2026 - 14:35 EST

Investigating

We are aware of an issue preventing images from displaying as expected on Composer websites, impacting a subset of US Central clients. We are working to resolve this issue and will provide additional updates as soon as possible.
Posted Feb 10, 2026 - 10:08 EST
This incident affects: School Websites (Composer US Central).