Degraded Performance Issue - US Central
Incident Report for Finalsite
Resolved
This incident has been resolved.
Posted Sep 12, 2022 - 13:04 EDT
Monitoring
A fix has been implemented and we're continuing to monitor performance at this time.
Posted Sep 12, 2022 - 09:41 EDT
Investigating
Our team is investigating performance/availability problems on some US Central websites. We will provide additional information as soon as possible.
Posted Sep 12, 2022 - 09:29 EDT
This incident affected: Composer US Central.