The final release to the remaining servers was postponed to September 2nd. The maintenance window will be the same (1:00 am to 4:00 am ET). During this window, you may experience intermittent connectivity issues.
Posted Sep 02, 2024 - 04:00 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 26, 2024 - 01:00 EDT
Scheduled
We are excited to announce our next Community Engagement 10.51 release for Mass Notifications, and Teacher Communication. Our releases are staggered amongst our servers, and they are scheduled for August 21st and 26th. The maintenance window will be from 1:00 am to 4:00 am ET on these dates. During this window, you may experience intermittent connectivity issues.
Catch up on the latest releases & enhancements in Finalsite's digital strategies with our software update blog. Explore bug fixes, new features & more! https://cesupport.finalsite.com/hc/en-us
Posted Aug 20, 2024 - 10:12 EDT
This scheduled maintenance affected: Community Engagement Products (formerly Blackboard K12) (Mass Notifications).