Connect is currently experiencing phone system issues.
Incident Report for Finalsite
Resolved
This phone issue has been resolved. The phones are operating as expected. We apologize for any inconvenience.
Posted Apr 02, 2024 - 11:59 EDT
Update
We are continuing to investigate this issue.
Posted Apr 02, 2024 - 11:58 EDT
Investigating
Connect is currently experiencing issues with our phone systems. Please reach out to us at connectsupport@finalsite.com if you need assistance. We apologize for the inconvenience and will provide updates as they are available.
Posted Apr 02, 2024 - 11:31 EDT
This incident affected: Community Engagement Products (formerly Blackboard K12) (Connect).