Mass Notifications - Site Slowness

Incident Report for Finalsite

Resolved

Our development team has identified and resolved the issue causing a subset of clients to experience slowness when accessing the site.

We appreciate your patience as we worked to resolve the issue.
Posted Feb 28, 2025 - 16:16 EST

Investigating

A subset of clients are experiencing slowness when accessing the site, and at times they may be timing out. Our engineers are working towards a solution.

If you need to get out an emergency message and you cannot do so at this time, please reach out to our Support team and we will assist in getting that message out.
Posted Feb 28, 2025 - 15:17 EST
This incident affected: Community Engagement Products (formerly Blackboard K12) (Mass Notifications).