Composer Performance Issues

Incident Report for Finalsite

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 20:05 EDT

Monitoring

We are continuing to monitor the situation, but we are seeing Composer websites performing as expected at this time. If you are seeing any residual issues, please contact Support.
Posted Jun 12, 2025 - 17:17 EDT

Identified

Our initial assessment is that this is related to broader issues being encountered by Google and other services. We are monitoring the situation and will provide additional updates as soon as possible.
Posted Jun 12, 2025 - 15:13 EDT

Investigating

Our team is aware of an issue that may be impacting Composer performance at this time, particularly pages on the backend of the platform. More updates to follow shortly.
Posted Jun 12, 2025 - 14:18 EDT
This incident affected: School Websites (Composer US East, Composer US Central, Composer US West, Composer UK, Composer Asia).