Degraded Performance - US Central
Incident Report for Finalsite
Resolved
This issue has been resolved.
Posted Apr 10, 2024 - 20:56 EDT
Monitoring
Sites are continuing to perform as expected and we are monitoring at this time. If you are encountering any issues, please contact our Support team.
Posted Apr 10, 2024 - 12:11 EDT
Update
We are seeing improved performance at this time, but are continuing to investigate.
Posted Apr 10, 2024 - 00:22 EDT
Investigating
Our team is investigating performance/availability problems on some US Central websites. We will provide additional information as soon as possible.
Posted Apr 09, 2024 - 20:45 EDT
This incident affected: Composer CMS (Content Management System) (Composer US Central).