Connect: SMS Sending Issue

Incident Report for Finalsite

Monitoring

Changes have been implemented, and monitoring is ongoing.
Posted Nov 27, 2025 - 11:30 EST

Investigating

We are aware of an incident that may be preventing a subset of SMS traffic from sending properly. We are actively working to resolve this and will provide an update as soon as possible.
Posted Nov 26, 2025 - 14:58 EST
This incident affects: Communication Tools (Connect).