Mass Notification – Messages Not Sending for a Subset of Clients

Incident Report for Finalsite

Resolved

The issue has been resolved, and all messages are once again sending. Thank you for your patience while we worked on the resolution.
Posted Jul 22, 2025 - 11:51 EDT

Investigating

Our development team has discovered an issue that is causing some messages to get stuck in a Current status without any sending. This is identifiable by the Current status and an empty progress bar. We are working to resolve this as quickly as possible.

If you are affected by this issue and need an emergency message sent out, please contact the support team and we will assist you in getting the message out.

We apologize for the inconvenience.
Posted Jul 22, 2025 - 10:36 EDT
This incident affected: Communication Tools (Mass Notifications, Messages XR Enterprise).