SMS Sending Delay

Incident Report for Finalsite

Resolved

Working with our third party provider, this issue is now resolved as of 9am CT. We again apologize for any inconvenience this may have caused, and please do reach out to our Support team if you have any further questions or concerns.
Posted Aug 05, 2025 - 11:35 EDT

Investigating

For a small subset of clients, there is a delay in SMS sending (phone calls and emails are processing as expected). This can range from a few minutes to an hour. Our development team is aware of the issue and working towards a resolution.

We apologize for any inconvenience this may cause.
Posted Aug 04, 2025 - 15:15 EDT
This incident affected: Communication Tools (Mass Notifications, Messages XR Enterprise).