Performance Issues

Incident Report for Finalsite

Resolved

This issue has been resolved and sites are now performing as expected. If you are experiencing any lingering issues, please contact Support.
Posted May 30, 2025 - 14:52 EDT

Investigating

We are currently investigating issues impacting login, and other functionality for a subset of clients in our US East region. We will provide additional updates shortly.
Posted May 30, 2025 - 14:29 EDT
This incident affected: School Websites (Composer US East).