Finalsite Store: Performance Issue

Incident Report for Finalsite

Resolved

This issue affecting Finalsite Store has been fully resolved, thank you for your patience.
Posted May 08, 2025 - 13:32 EDT

Monitoring

Finalsite Store is once again loading as expected, we are continuing to monitor at this time. We will provide any additional updates here.
Posted May 08, 2025 - 09:58 EDT

Investigating

Our team is aware of an issue impacting Finalsite Store, and storefronts not loading properly in website pages. We will provide additional updates as soon as possible.
Posted May 08, 2025 - 09:07 EDT
This incident affected: School Websites (Composer US East, Composer US Central, Composer US West, Composer UK, Composer Asia).